[app] | |
# (str) Title of your application | |
title = g4f | |
# (str) Package name | |
package.name = g4a | |
# (str) Package domain (needed for android/ios packaging) | |
package.domain = org.g4f | |
# (str) Source code where the main.py live | |
source.dir = . | |
# (list) Source files to include (let empty to include all the files) | |
#source.include_exts = py,png,jpg,kv,atlas,html,css,js,png | |
# (list) List of inclusions using pattern matching | |
source.include_patterns = main.py | |
# (list) Source files to exclude (let empty to not exclude anything) | |
#source.exclude_exts = spec | |
# (list) List of directory to exclude (let empty to not exclude anything) | |
source.exclude_dirs = etc, docker, docs, .github | |
# (list) List of exclusions using pattern matching | |
# Do not prefix with './' | |
#source.exclude_patterns = license,images/*/*.jpg | |
# (str) Application versioning (method 1) | |
version = 0.1 | |
# (str) Application versioning (method 2) | |
# version.regex = __version__ = ['"](.*)['"] | |
# version.filename = %(source.dir)s/main.py | |
# (list) Application requirements | |
# comma separated e.g. requirements = sqlite3,kivy | |
requirements = python3==3.11.7,kivy==2.3.0,aiohttp==3.9.3,aiosignal==1.3.1,attrs==23.2.0,beautifulsoup4==4.12.3,certifi==2024.2.2,charset-normalizer==3.3.2,docutils==0.20.1,frozenlist==1.4.1,idna==3.6,multidict==6.0.5,requests==2.31.0,soupsieve==2.5,Unidecode==1.3.8,urllib3==2.2.0,yarl==1.9.4,pywebview,pillow,platformdirs,python-for-android,plyer,/home/heiner/gpt4free2/,proxy_tools,bottle,typing_extensions,cryptography,brotli,android | |
# (str) Custom source folders for requirements | |
# Sets custom source for any requirements with recipes | |
# requirements.source.g4f = /home/.../gpt4free | |
# (str) Presplash of the application | |
#presplash.filename = %(source.dir)s/data/presplash.png | |
# (str) Icon of the application | |
icon.filename = %(source.dir)s/g4f/gui/client/static/img/android-chrome-512x512.png | |
# (list) Supported orientations | |
# Valid options are: landscape, portrait, portrait-reverse or landscape-reverse | |
orientation = portrait | |
# (list) List of service to declare | |
#services = NAME:ENTRYPOINT_TO_PY,NAME2:ENTRYPOINT2_TO_PY | |
# | |
# OSX Specific | |
# | |
# | |
# author = © Copyright Info | |
# change the major version of python used by the app | |
osx.python_version = 3 | |
# Kivy version to use | |
osx.kivy_version = 1.9.1 | |
# | |
# Android specific | |
# | |
# (bool) Indicate if the application should be fullscreen or not | |
fullscreen = 0 | |
# (string) Presplash background color (for android toolchain) | |
# Supported formats are: #RRGGBB #AARRGGBB or one of the following names: | |
# red, blue, green, black, white, gray, cyan, magenta, yellow, lightgray, | |
# darkgray, grey, lightgrey, darkgrey, aqua, fuchsia, lime, maroon, navy, | |
# olive, purple, silver, teal. | |
#android.presplash_color = #FFFFFF | |
# (string) Presplash animation using Lottie format. | |
# see https://lottiefiles.com/ for examples and https://airbnb.design/lottie/ | |
# for general documentation. | |
# Lottie files can be created using various tools, like Adobe After Effect or Synfig. | |
#android.presplash_lottie = "path/to/lottie/file.json" | |
# (str) Adaptive icon of the application (used if Android API level is 26+ at runtime) | |
#icon.adaptive_foreground.filename = %(source.dir)s/data/icon_fg.png | |
#icon.adaptive_background.filename = %(source.dir)s/data/icon_bg.png | |
# (list) Permissions | |
# (See https://python-for-android.readthedocs.io/en/latest/buildoptions/#build-options-1 for all the supported syntaxes and properties) | |
android.permissions = android.permission.INTERNET, android.permission.CAMERA, android.permission.WRITE_EXTERNAL_STORAGE, android.permission.READ_EXTERNAL_STORAGE | |
# (list) features (adds uses-feature -tags to manifest) | |
#android.features = android.hardware.usb.host | |
# (int) Target Android API, should be as high as possible. | |
android.api = 21 | |
#31 | |
# (int) Minimum API your APK / AAB will support. | |
android.minapi = 21 | |
# (int) Android SDK version to use | |
#android.sdk = 23 | |
# File path exposed error | |
# (str) Android NDK version to use | |
#android.ndk = 23b | |
# (int) Android NDK API to use. This is the minimum API your app will support, it should usually match android.minapi. | |
#android.ndk_api = 21 | |
# (bool) Use --private data storage (True) or --dir public storage (False) | |
#android.private_storage = True | |
# (str) Android NDK directory (if empty, it will be automatically downloaded.) | |
#android.ndk_path = | |
# (str) Android SDK directory (if empty, it will be automatically downloaded.) | |
#android.sdk_path = | |
# (str) ANT directory (if empty, it will be automatically downloaded.) | |
#android.ant_path = | |
# (bool) If True, then skip trying to update the Android sdk | |
# This can be useful to avoid excess Internet downloads or save time | |
# when an update is due and you just want to test/build your package | |
# android.skip_update = False | |
# (bool) If True, then automatically accept SDK license | |
# agreements. This is intended for automation only. If set to False, | |
# the default, you will be shown the license when first running | |
# buildozer. | |
# android.accept_sdk_license = False | |
# (str) Android entry point, default is ok for Kivy-based app | |
#android.entrypoint = org.kivy.android.PythonActivity | |
# (str) Full name including package path of the Java class that implements Android Activity | |
# use that parameter together with android.entrypoint to set custom Java class instead of PythonActivity | |
#android.activity_class_name = org.kivy.android.PythonActivity | |
# (str) Extra xml to write directly inside the <manifest> element of AndroidManifest.xml | |
# use that parameter to provide a filename from where to load your custom XML code | |
#android.extra_manifest_xml = ./src/android/extra_manifest.xml | |
# (str) Extra xml to write directly inside the <manifest><application> tag of AndroidManifest.xml | |
# use that parameter to provide a filename from where to load your custom XML arguments: | |
#android.extra_manifest_application_arguments = ./src/android/extra_manifest_application_arguments.xml | |
# (str) Full name including package path of the Java class that implements Python Service | |
# use that parameter to set custom Java class which extends PythonService | |
#android.service_class_name = org.kivy.android.PythonService | |
# (str) Android app theme, default is ok for Kivy-based app | |
# android.apptheme = "@android:style/Theme.NoTitleBar" | |
# (list) Pattern to whitelist for the whole project | |
#android.whitelist = | |
# (str) Path to a custom whitelist file | |
#android.whitelist_src = | |
# (str) Path to a custom blacklist file | |
#android.blacklist_src = | |
# (list) List of Java .jar files to add to the libs so that pyjnius can access | |
# their classes. Don't add jars that you do not need, since extra jars can slow | |
# down the build process. Allows wildcards matching, for example: | |
# OUYA-ODK/libs/*.jar | |
android.add_jars = /home/heiner/.local/lib/python3.10/site-packages/webview/lib/pywebview-android.jar | |
# (list) List of Java files to add to the android project (can be java or a | |
# directory containing the files) | |
#android.add_src = | |
# (list) Android AAR archives to add | |
#android.add_aars = | |
# (list) Put these files or directories in the apk assets directory. | |
# Either form may be used, and assets need not be in 'source.include_exts'. | |
# 1) android.add_assets = source_asset_relative_path | |
# 2) android.add_assets = source_asset_path:destination_asset_relative_path | |
#android.add_assets = | |
# (list) Put these files or directories in the apk res directory. | |
# The option may be used in three ways, the value may contain one or zero ':' | |
# Some examples: | |
# 1) A file to add to resources, legal resource names contain ['a-z','0-9','_'] | |
# android.add_resources = my_icons/all-inclusive.png:drawable/all_inclusive.png | |
# 2) A directory, here 'legal_icons' must contain resources of one kind | |
# android.add_resources = legal_icons:drawable | |
# 3) A directory, here 'legal_resources' must contain one or more directories, | |
# each of a resource kind: drawable, xml, etc... | |
# android.add_resources = legal_resources | |
#android.add_resources = | |
# (list) Gradle dependencies to add | |
#android.gradle_dependencies = | |
# (bool) Enable AndroidX support. Enable when 'android.gradle_dependencies' | |
# contains an 'androidx' package, or any package from Kotlin source. | |
# android.enable_androidx requires android.api >= 28 | |
#android.enable_androidx = True | |
# (list) add java compile options | |
# this can for example be necessary when importing certain java libraries using the 'android.gradle_dependencies' option | |
# see https://developer.android.com/studio/write/java8-support for further information | |
# android.add_compile_options = "sourceCompatibility = 1.8", "targetCompatibility = 1.8" | |
# (list) Gradle repositories to add {can be necessary for some android.gradle_dependencies} | |
# please enclose in double quotes | |
# e.g. android.gradle_repositories = "maven { url 'https://kotlin.bintray.com/ktor' }" | |
#android.add_gradle_repositories = | |
# (list) packaging options to add | |
# see https://google.github.io/android-gradle-dsl/current/com.android.build.gradle.internal.dsl.PackagingOptions.html | |
# can be necessary to solve conflicts in gradle_dependencies | |
# please enclose in double quotes | |
# e.g. android.add_packaging_options = "exclude 'META-INF/common.kotlin_module'", "exclude 'META-INF/*.kotlin_module'" | |
#android.add_packaging_options = | |
# (list) Java classes to add as activities to the manifest. | |
#android.add_activities = com.example.ExampleActivity | |
# (str) OUYA Console category. Should be one of GAME or APP | |
# If you leave this blank, OUYA support will not be enabled | |
#android.ouya.category = GAME | |
# (str) Filename of OUYA Console icon. It must be a 732x412 png image. | |
#android.ouya.icon.filename = %(source.dir)s/data/ouya_icon.png | |
# (str) XML file to include as an intent filters in <activity> tag | |
#android.manifest.intent_filters = | |
# (list) Copy these files to src/main/res/xml/ (used for example with intent-filters) | |
#android.res_xml = PATH_TO_FILE, | |
# (str) launchMode to set for the main activity | |
#android.manifest.launch_mode = standard | |
# (str) screenOrientation to set for the main activity. | |
# Valid values can be found at https://developer.android.com/guide/topics/manifest/activity-element | |
#android.manifest.orientation = fullSensor | |
# (list) Android additional libraries to copy into libs/armeabi | |
#android.add_libs_armeabi = libs/android/*.so | |
#android.add_libs_armeabi_v7a = libs/android-v7/*.so | |
#android.add_libs_arm64_v8a = libs/android-v8/*.so | |
#android.add_libs_x86 = libs/android-x86/*.so | |
#android.add_libs_mips = libs/android-mips/*.so | |
# (bool) Indicate whether the screen should stay on | |
# Don't forget to add the WAKE_LOCK permission if you set this to True | |
#android.wakelock = False | |
# (list) Android application meta-data to set (key=value format) | |
#android.meta_data = | |
# (list) Android library project to add (will be added in the | |
# project.properties automatically.) | |
#android.library_references = | |
# (list) Android shared libraries which will be added to AndroidManifest.xml using <uses-library> tag | |
#android.uses_library = | |
# (str) Android logcat filters to use | |
#android.logcat_filters = *:S python:D | |
# (bool) Android logcat only display log for activity's pid | |
#android.logcat_pid_only = False | |
# (str) Android additional adb arguments | |
#android.adb_args = -H host.docker.internal | |
# (bool) Copy library instead of making a libpymodules.so | |
#android.copy_libs = 1 | |
# (list) The Android archs to build for, choices: armeabi-v7a, arm64-v8a, x86, x86_64 | |
# In past, was `android.arch` as we weren't supporting builds for multiple archs at the same time. | |
android.archs = arm64-v8a | |
#, armeabi-v7a | |
# (int) overrides automatic versionCode computation (used in build.gradle) | |
# this is not the same as app version and should only be edited if you know what you're doing | |
# android.numeric_version = 1 | |
# (bool) enables Android auto backup feature (Android API >=23) | |
android.allow_backup = True | |
# (str) XML file for custom backup rules (see official auto backup documentation) | |
# android.backup_rules = | |
# (str) If you need to insert variables into your AndroidManifest.xml file, | |
# you can do so with the manifestPlaceholders property. | |
# This property takes a map of key-value pairs. (via a string) | |
# Usage example : android.manifest_placeholders = [myCustomUrl:\"org.kivy.customurl\"] | |
# android.manifest_placeholders = [:] | |
# (bool) Skip byte compile for .py files | |
# android.no-byte-compile-python = False | |
# (str) The format used to package the app for release mode (aab or apk or aar). | |
# android.release_artifact = aab | |
# (str) The format used to package the app for debug mode (apk or aar). | |
# android.debug_artifact = apk | |
# | |
# Python for android (p4a) specific | |
# | |
# (str) python-for-android URL to use for checkout | |
#p4a.url = | |
# (str) python-for-android fork to use in case if p4a.url is not specified, defaults to upstream (kivy) | |
#p4a.fork = kivy | |
# (str) python-for-android branch to use, defaults to master | |
#p4a.branch = master | |
# (str) python-for-android specific commit to use, defaults to HEAD, must be within p4a.branch | |
#p4a.commit = HEAD | |
# (str) python-for-android git clone directory (if empty, it will be automatically cloned from github) | |
#p4a.source_dir = | |
# (str) The directory in which python-for-android should look for your own build recipes (if any) | |
#p4a.local_recipes = | |
# (str) Filename to the hook for p4a | |
#p4a.hook = | |
# (str) Bootstrap to use for android builds | |
# p4a.bootstrap = sdl2 | |
# (int) port number to specify an explicit --port= p4a argument (eg for bootstrap flask) | |
#p4a.port = | |
# Control passing the --use-setup-py vs --ignore-setup-py to p4a | |
# "in the future" --use-setup-py is going to be the default behaviour in p4a, right now it is not | |
# Setting this to false will pass --ignore-setup-py, true will pass --use-setup-py | |
# NOTE: this is general setuptools integration, having pyproject.toml is enough, no need to generate | |
# setup.py if you're using Poetry, but you need to add "toml" to source.include_exts. | |
#p4a.setup_py = false | |
# (str) extra command line arguments to pass when invoking pythonforandroid.toolchain | |
#p4a.extra_args = | |
# | |
# iOS specific | |
# | |
# (str) Path to a custom kivy-ios folder | |
#ios.kivy_ios_dir = ../kivy-ios | |
# Alternately, specify the URL and branch of a git checkout: | |
ios.kivy_ios_url = https://github.com/kivy/kivy-ios | |
ios.kivy_ios_branch = master | |
# Another platform dependency: ios-deploy | |
# Uncomment to use a custom checkout | |
#ios.ios_deploy_dir = ../ios_deploy | |
# Or specify URL and branch | |
ios.ios_deploy_url = https://github.com/phonegap/ios-deploy | |
ios.ios_deploy_branch = 1.10.0 | |
# (bool) Whether or not to sign the code | |
ios.codesign.allowed = false | |
# (str) Name of the certificate to use for signing the debug version | |
# Get a list of available identities: buildozer ios list_identities | |
#ios.codesign.debug = "iPhone Developer: <lastname> <firstname> (<hexstring>)" | |
# (str) The development team to use for signing the debug version | |
#ios.codesign.development_team.debug = <hexstring> | |
# (str) Name of the certificate to use for signing the release version | |
#ios.codesign.release = %(ios.codesign.debug)s | |
# (str) The development team to use for signing the release version | |
#ios.codesign.development_team.release = <hexstring> | |
# (str) URL pointing to .ipa file to be installed | |
# This option should be defined along with `display_image_url` and `full_size_image_url` options. | |
#ios.manifest.app_url = | |
# (str) URL pointing to an icon (57x57px) to be displayed during download | |
# This option should be defined along with `app_url` and `full_size_image_url` options. | |
#ios.manifest.display_image_url = | |
# (str) URL pointing to a large icon (512x512px) to be used by iTunes | |
# This option should be defined along with `app_url` and `display_image_url` options. | |
#ios.manifest.full_size_image_url = | |
[buildozer] | |
# (int) Log level (0 = error only, 1 = info, 2 = debug (with command output)) | |
log_level = 2 | |
# (int) Display warning if buildozer is run as root (0 = False, 1 = True) | |
warn_on_root = 1 | |
# (str) Path to build artifact storage, absolute or relative to spec file | |
# build_dir = ./.buildozer | |
# (str) Path to build output (i.e. .apk, .aab, .ipa) storage | |
# bin_dir = ./bin | |
# ----------------------------------------------------------------------------- | |
# List as sections | |
# | |
# You can define all the "list" as [section:key]. | |
# Each line will be considered as a option to the list. | |
# Let's take [app] / source.exclude_patterns. | |
# Instead of doing: | |
# | |
#[app] | |
#source.exclude_patterns = license,data/audio/*.wav,data/images/original/* | |
# | |
# This can be translated into: | |
# | |
#[app:source.exclude_patterns] | |
#license | |
#data/audio/*.wav | |
#data/images/original/* | |
# | |
# ----------------------------------------------------------------------------- | |
# Profiles | |
# | |
# You can extend section / key with a profile | |
# For example, you want to deploy a demo version of your application without | |
# HD content. You could first change the title to add "(demo)" in the name | |
# and extend the excluded directories to remove the HD content. | |
# | |
#[app@demo] | |
#title = My Application (demo) | |
# | |
#[app:source.exclude_patterns@demo] | |
#images/hd/* | |
# | |
# Then, invoke the command line with the "demo" profile: | |
# | |
#buildozer --profile demo android debug | |